Search Fishin.com

Page 1 of 2 12 LastLast
Results 1 to 12 of 21
  1. #1
    Join Date
    Jan 2008
    Posts
    142
    Post Thanks / Like

    Humminbird Problem

    I have a Humminbird 998 CSI unit on my console. While we were on Lake Guntersville last week, the depth finder didn't work for pretty much the entire trip. It was stuck on 3.4 ft no matter where we were. I called Humminbird tech support and they said to take the maximum depth off of automatic and set it for 10 feet more than the maximum depth. So we set it for 40 feet. It didn't help. Got back home and went to a local lake yesterday and it worked fine. Any suggestions?

  2. #2
    Join Date
    Sep 2011
    Posts
    194
    Post Thanks / Like
    Transducer may need to adjusted or you have interference from another electronic or even your outboard.
    Likes GeoFisher liked this post

  3. #3
    Join Date
    Jan 2008
    Posts
    142
    Post Thanks / Like
    Checked the transducer and it was fine. I guess interference could be a possibility although it worked fine on Laurel yesterday.

  4. #4
    Join Date
    Apr 2015
    Location
    Monticello, Ky
    Posts
    2
    Post Thanks / Like
    My DI and SI quit working all together

  5. #5
    Join Date
    Apr 2008
    Location
    Campbellsville, KY
    Posts
    1,883
    Post Thanks / Like
    Sounds like the beginnings of a software issue possibly. Thats how mine started was with the depth locking up, then itd work for awhile and got progressively worse. Eventually the screen froze up all together and i got to pay Hbird an arm and a leg to fix it

  6. #6
    Join Date
    Jan 2008
    Posts
    142
    Post Thanks / Like
    Quote Originally Posted by Fishin is life View Post
    Sounds like the beginnings of a software issue possibly. Thats how mine started was with the depth locking up, then itd work for awhile and got progressively worse. Eventually the screen froze up all together and i got to pay Hbird an arm and a leg to fix it
    That's what I'm afraid of. Might be time to start looking at RayMarine products!

  7. #7
    Join Date
    Dec 1969
    Location
    New Albany, Indiana.
    Posts
    8,102
    Post Thanks / Like
    Quote Originally Posted by voeller101 View Post
    That's what I'm afraid of. Might be time to start looking at RayMarine products!
    Flash it first.............

    See if that fixes the issue.

  8. #8
    Join Date
    Jan 2008
    Posts
    142
    Post Thanks / Like
    Not sure what you mean by flashing it.

  9. #9
    Join Date
    Dec 1969
    Location
    New Albany, Indiana.
    Posts
    8,102
    Post Thanks / Like
    Quote Originally Posted by voeller101 View Post
    Not sure what you mean by flashing it.
    Using the Hummingbird Windows software for your PC, you can download a firmware upgrade, if they exist. Those upgrades generally provide "fixes" to things that are broke. I've used them a few times, and have fixed issues on both of my units.

    You need to be "familiar" with the technology and methodology used to flash your fish finder, otherwise you can turn it into a hunk of useless plastic.

    There are lots of videos of "flashing" your fishfinder on youtube.

    Later,

    Geo

  10. #10
    Join Date
    Jan 2008
    Posts
    142
    Post Thanks / Like
    Quote Originally Posted by GeoFisher View Post
    Using the Hummingbird Windows software for your PC, you can download a firmware upgrade, if they exist. Those upgrades generally provide "fixes" to things that are broke. I've used them a few times, and have fixed issues on both of my units.

    You need to be "familiar" with the technology and methodology used to flash your fish finder, otherwise you can turn it into a hunk of useless plastic.

    There are lots of videos of "flashing" your fishfinder on youtube.

    Later,

    Geo
    Ok, thanks. I have done a software update on it before using a microSD card. It's probably been a year or so though, so I'll definitely give that a shot.
    Likes GeoFisher liked this post

  11. #11
    Join Date
    Dec 1969
    Location
    New Albany, Indiana.
    Posts
    8,102
    Post Thanks / Like
    Quote Originally Posted by voeller101 View Post
    Ok, thanks. I have done a software update on it before using a microSD card. It's probably been a year or so though, so I'll definitely give that a shot.
    That is EXACTLY what I was talking about.

    Mine was acting up and I found a firmware upgrade that fixed it.

  12. #12
    Join Date
    Jan 2008
    Posts
    142
    Post Thanks / Like
    Quote Originally Posted by GeoFisher View Post
    That is EXACTLY what I was talking about.

    Mine was acting up and I found a firmware upgrade that fixed it.

    Thanks, GeoFisher! I hope that takes care of it. As it is right now when we're in Alabama, it's just a really expensive water temperature gauge. Lol

Similar Threads

  1. Spending Problem or Revenue Problem
    By GeoFisher in forum "Off Topic" Posts
    Replies: 0
    Last Post: 04-21-2013, 01:57 PM
  2. problem
    By kygorski in forum Kentucky Discussion Board
    Replies: 1
    Last Post: 01-31-2011, 11:23 PM
  3. GPS problem
    By gillman in forum Kentucky Discussion Board
    Replies: 2
    Last Post: 01-19-2010, 05:23 PM
  4. Will This Be a Problem?
    By bassin_bug in forum "Off Topic" Posts
    Replies: 5
    Last Post: 05-11-2009, 12:20 PM
  5. Problem
    By zx150 in forum Kentucky Discussion Board
    Replies: 1
    Last Post: 10-16-2006, 02:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •